October 02, 2014,14:20:00 *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Welcome to my website...
 
   Home   Help Login Register  
Pages: [1]   Go Down
  Print  
Author
[EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU]
Topic: 17PW15-8 power supply  (Read 6819 times)
0 Members and 1 Guest are viewing this topic.
norman
Sr. Member
****
Posts: 147


Email
« on: June 16, 2008,10:38:37 »

Hi guys,does anyone have a circuit for this power supply 17PW15-8 fitted to a Wharfedale LCD3210H DAF television.It goes to standby after a short time, I have changed some electrolytics and the two 15nf caps (of which one was open circuit) but I still have the fault. Norman brinda
Logged
alhootalhoot
Newbie
*
Posts: 2



Email
« Reply #1 on: July 03, 2008,09:39:01 »

Hi there,
Try replacing the mos-fet s in the same circuitry of C877 and 878,
sorry i don't have the circuit diagram.
let us know if this helps.

it would help if you establish wether you get a secondary voltage rise then collapse after switch-on attempt from standby,if there isn't any, then it is almost certain it is the start-up circuit (i.e: no bias signal on the gate of the FET's or even faulty mos-fet s).
Logged
norman
Sr. Member
****
Posts: 147


Email
« Reply #2 on: July 04, 2008,07:38:58 »

Thanks for the reply, I think I have diagnosed this one, the ic that feeds the fets type SG3525A is faulty. If I squirt it with some freezer it works for much longer and if you keep freezing the chip it will work all day. I am waiting for a couple of the ics coming so will let you know how it goes. I have a circuit for it now, from the Hitachi website. brinda
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
 

MKPortal ©2003-2007 mkportal.it