Author Topic: Bush LE-40GCL-A1 Eeprom issues ?  (Read 356 times)

0 Members and 1 Guest are viewing this topic.

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3154
    • Email
Bush LE-40GCL-A1 Eeprom issues ?
« on: April 13, 2017,09:38:58 »
Hi folks,

Just got one in where Red s/by turns to Blue and then flashing Blue and steady Red. No functions at all.

Tend to suspect corrupted Eeprom 25Q64 flash. Note the two different screens use different bins, mine is the T395HJ-PE1-DY2  V-A2.

Read somewhere that if the set has a 'cycling backlight' the M'Proc will corrupt the new Eeprom. My backlight does nothing.

Any thoughts ? - Chris.

Later - Got replacement Eeprom so blanked original and copied new bin - Set now turns on, backlight functions but no OSG. Thought check T/con fuse - Volts either side. Noticed that the backlight cuts out for a second every minute, which looks like backlight cycling and maybe a duff M/Proc.
Waiting for an Eeprom for the other screen version - Will give it a go then upload bins to Quuq as might be useful. Loaded the other Bin file - Red Led and no go at all - Guess new board.
« Last Edit: April 16, 2017,09:46:22 by Turnip »

Mulja tv repair portal

Bush LE-40GCL-A1 Eeprom issues ?
« on: April 13, 2017,09:38:58 »

cheeky2

  • Sr. Member
  • ****
  • Posts: 154
Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #1 on: April 22, 2017,05:45:56 »
 I have come across spi flash ics that you can write to ok and compare ok. However they very quickly corrupt again!
So best to write a good dump into a new flash ic. I tend to use the MX25L6406E ics as reasonably priced or winbond w25q64 cheaper.

Costica LCD

  • Newbie
  • *
  • Posts: 5
    • Email
Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #2 on: April 22, 2017,10:11:08 »
Please the motherboard series

Mulja tv repair portal

Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #2 on: April 22, 2017,10:11:08 »

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3154
    • Email
Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #3 on: April 22, 2017,12:16:58 »
Hi Cheeky, and thanks.

Found I could read/write/verify with the Eeprom on the board. As I did it several times with the two different bins for screen options and always got the same outcomes, tend to feel that the chap who suggested that if the backlight cycles, the M/proc is duff might be right. Mind you, have some blanks coming from China to programme.

Noticed a board on Ebay where they don't specify screen, but thought go for it as have the bins.
Gather supplied board is TP-SIS321.PT751 - Chris.


cheeky2

  • Sr. Member
  • ****
  • Posts: 154
Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #4 on: April 23, 2017,07:18:09 »
What this one on ebay for 20 or offer
http://www.ebay.co.uk/itm/112378641663
 I tend to always ask the buyers what screen was fitted as may save you some time long run (if they bothered making a note of it!).

 Also check orientation of screen connector and it lining up correctly in pins! Sometimes the basics get overlooked!
 I tend to take a picture of board just in case with connectors attached!
 Always good for a cross reference when reassembling sometime later after parts replaced!

Turnip

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3154
    • Email
Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #5 on: April 24, 2017,11:04:10 »
Hi Cheeky,

Guess mine had gone from Ebay as I'd bought it. Not sure whether the 39 or 40 screen version but when it arrived I checked the Eeprom and at area 67B550 where the 40 was full of stuff but the 39 had nothing - Seems mine is the 39 version as that area is empty.

Agree about taking pictures, especially where the screen connector plug has less pins than the socket and isn't polarised, not unusual with crap Eastern stuff.

Getting to like Vestel more and more, just wish there less variations - Chris.

Mulja tv repair portal

Re: Bush LE-40GCL-A1 Eeprom issues ?
« Reply #5 on: April 24, 2017,11:04:10 »

 

Powered by EzPortal