Author Topic: LG 42PG20D: Sound OK - No Picture  (Read 61 times)

0 Members and 1 Guest are viewing this topic.

downunder

  • Hero Member
  • *****
  • Posts: 822
LG 42PG20D: Sound OK - No Picture
« on: November 12, 2017,02:07:28 »

Hi all, Currently have this LG plasma which clicks on ok, all psu volts are present including Vs and Va but no picture appears. The green LED on the control board shows a solid green - no flashing. The Y-Sus heatsinks remain cold and no test patterns are generated via the Auto Gen test points. I'm thinking control board but I've never ever had to replace one. Don't have any boards to try so I might be
fleabay bound. So, what does a solid green LED mean - Y-Sus, Main, Control?                     Bruce

Mulja tv repair portal

LG 42PG20D: Sound OK - No Picture
« on: November 12, 2017,02:07:28 »

vinceroger69

  • Full Member
  • ***
  • Posts: 75
    • Email
Re: LG 42PG20D: Sound OK - No Picture
« Reply #1 on: November 12, 2017,09:37:47 »
Hi not sure if it will tell you in the service manual but heres a link too it
http://www.jordansmanuals.com/ServiceManuals/LG/TV/PLASMA/42PG20D/40PG20D%20Service%20Manual.pdf

downunder

  • Hero Member
  • *****
  • Posts: 822
Re: LG 42PG20D: Sound OK - No Picture
« Reply #2 on: November 14, 2017,04:18:01 »

Thanks Vince, as it turns out, I found a Y-Sus and Control board in some spares I had at home (I work from a shop). It was the Y-Sus, as

it appears the LED on the Control board remains a solid green at all times. Situation resolved.                  Bruce

Mulja tv repair portal

Re: LG 42PG20D: Sound OK - No Picture
« Reply #2 on: November 14, 2017,04:18:01 »

 

Powered by EzPortal
download